I'm not going to explain why it happened because I have no clue but I've got the workaround for it until it's fixed. If the fed thumbnail deal is showing vertically for you and overlapping everything then here's what you do.

Go to Settings at the top of the page

Click General Settings on the left-hand side of the page

Scroll to Miscellaneous Options -> Forum Skin

Change it to VB4 Default Style

Boom. Fancy site gone, ugly site initiated ... but now you can post again.